jobberBase Community

Welcome to jobberBase Developer Community!

You are not logged in.

Announcement

Announcement for new users: in order to combat the ever increasing spam, we no longer allow new users to post links in the message body. This limitation is automatically lifted once a new user has a specific number of 'valid' posts.

You can post links like google.com which will be rendered as text but you will not be able to post messages that contain complete URLs like www.google.com

Thank you for your understanding!

#1 2010-04-05 14:03:47

dj.dule
Member
Registered: 2010-02-21
Posts: 13

How to upgrade live site from 1.8 to 1.9 ?

Hi all,

I have live site running 1.8 and would like to upgrade it to 1.9 ? I found following documentation:
http://www.jobberbase.com/forum/topic24 … to-19.html (guide how to update database)
and
http://wiki.jobberbase.com/install (installation guide on wiki)

but no documents on how to upgrade.

My questions are:
-Do I still need to follow database update steps ?
-What else should I do to upgrade to 1.9 ? I suppose I should delete old install and do installation of 1.9, skipping database step, right ?

Thank you in advance.

Dusan

Offline

#2 2010-04-10 11:20:07

tedi
Member
Registered: 2010-02-07
Posts: 3

Re: How to upgrade live site from 1.8 to 1.9 ?

Hi,

Same problem here. I assume the process consists on:
- Backing up all data.
- Replacing all files (keeping customizations if needed).
- Updating database.

Am I wrong?

Thanks.

Offline

#3 2010-04-18 02:44:59

ultraimports
Member
Registered: 2010-03-11
Posts: 3

Re: How to upgrade live site from 1.8 to 1.9 ?

Same here too smile. I would like to put on 1.9, but am hesitant till someone has "experienced" it smile.

Offline

#4 2010-04-18 11:38:02

dj.dule
Member
Registered: 2010-02-21
Posts: 13

Re: How to upgrade live site from 1.8 to 1.9 ?

At the end, I was brave to do it without manual, and it worked smile

I simply performed this:

-Backed up existing site to backup folder
-Backed up MySQL database using dump database form phpMyadmin
-Upgraded database from 1.8 to 1.9 (described http://www.jobberbase.com/forum/topic24 … o-19.html)
-Configured new version of software (described http://wiki.jobberbase.com/install) skipping steps explaining how to create database, since it is already there
-In part regarding database (Config and environments step) I put existing database data

And it worked without problems. Of course, all later customisations (Google Analytics, custom mails etc.) you would need to apply to your new code.

Hope this helps...

Offline

Board footer

Powered by FluxBB